0
Answered

i need a version support my mac version 10.8.5

ASA 4 years ago updated by Aleksandr 4 years ago 2

this version didn't work in my mac

Answer

Answer
Under review

Hello. System requirements for the UVD - Mac OS 10.9+

Answer
Under review

Hello. System requirements for the UVD - Mac OS 10.9+

Commenting disabled